different resultswith EPW v.5.1.0 and EPW v.5.3.1

General discussion around the EPW software

Moderator: hlee

Post Reply
inoka
Posts: 37
Joined: Sun Oct 16, 2016 5:41 pm
Affiliation:

different resultswith EPW v.5.1.0 and EPW v.5.3.1

Post by inoka »

Dear Developers

I was trying to get the scattering rates and the resistivity for my system using EPW v.5.1.0 (QE 6.4.1) and had to repeat it with the new version EPW v.5.3.1 (QE6.7). I am not sure why the resistivity results are almost doubled when using EPW v.5.3.1. The input files are the same except I changed the parameter "eptemp" in the older version to "temps" in new version and erased the nbndskip in the new version.

Same thing was checked by one of my other colleagues on two other systems and got the almost doubled results.

I can provide you my input files if you need to check.

Thank you
Inoka

hlee
Posts: 311
Joined: Thu Aug 03, 2017 12:24 pm
Affiliation: The University of Texas at Austin

Re: different resultswith EPW v.5.1.0 and EPW v.5.3.1

Post by hlee »

Dear Inoka:

I can just give you general answer.

I don't know about EPW v5.1, but it is a old version and in EPW v5.3.1 several bugs have been fixed (I guess even in EPW v5.2 some bugs were fixed).
They might be minor or major ones.

You can check the history of changes made to the relevant files at https://gitlab.com/QEF/q-e .

PS) If you obtain constantly the difference by a factor of about 2, it might be a minor issue, for instance, the fix of constant factor, etc.

Sincerely,

H. Lee

Post Reply