Solve anisotropic Eliashberg equations

Discussion around superconductivity

Moderator: hlee

Post Reply
dhw
Posts: 10
Joined: Thu Dec 03, 2020 7:46 am
Affiliation: none

Solve anisotropic Eliashberg equations

Post by dhw »

Hello administrator:
Recently,i had a problem with Solve Anisotropic Eliashberg Equations, where no error file was reported after an interrupt to the calculation process and got stuck in the output line below. What could be the problem?

Code: Select all

 
    
     Pade approximant of anisotropic Eliashberg equations from imaginary-axis to real-axis
     Cutoff frequency wscut =     1.0000
    
        pade Re[znorm] [eV] Re[delta] [eV]
        554            NaN            NaN
 
     Convergence was reached for N =    554 Pade approximants




and the input files is :

Code: Select all

&inputepw
  prefix      =  '  '
  amass(1)    = ,
  outdir      = './outdir/'
  ep_coupling = .true.
  elph        = .true.
  kmaps       = .true.
  epwread     = .true.
  epwwrite = .false.
  wannierize  = .false. 
!  num_iter    = 0
  dis_froz_min= 
  dis_froz_max= 
  proj(1) = ' '
  wdata(1) = 'Begin Kpoint_Path'
  wdata(2) = 'G 0.00 0.00 0.00   M 0.00 0.50 0.00'
  wdata(3) = 'M 0.00 0.50 0.00   K 0.333 0.333 0.00'
  wdata(4) = 'K 0.333 0.333 0.0  G 0.00 0.00 0.00'
  wdata(5) = 'End Kpoint_Path'
  wdata(6) = 'bands_plot = .true.'
  wdata(7) = 'bands_num_points = 55'
  wdata(8) = 'guiding_centres = .true.'
  wdata(9) = 'dis_num_iter = 5000'
  bands_skipped = 'exclude_bands = 1:25'
 
  system_2d=.true.
  etf_mem     =  1 
  nbndsub     =  ,
  iverbosity  = 2
  eps_acustic = 2.0    ! Lowest boundary for the phonon frequency 
  ephwrite    = .true. ! Writes .ephmat files used when Eliasberg = .true.
  fsthick     = 0.1  ! eV
  degaussw    = 0.01 ! eV
  nsmear      = 1
  nqsmear     = 1
  delta_smear = 0.01 ! eV
  degaussq     = 0.5 ! meV
  nqstep       = 500
  eliashberg  = .true.
  laniso = .true.
  limag = .true.
  lpade = .true.
  conv_thr_iaxis = 1.0d-4
!  max_memlt = 1.40d0
!  asr_typ = 'crystal'
  delta_approx = .true.,
!  elecselfen = .true.,
  phonselfen = .true.,
!  a2f = .true. ,
  wscut = 1.0   ! eV   Upper limit over frequency integration/summation in the Elisashberg eq
  nstemp   = 11     ! Nr. of temps
  temps    = 3.00 13.00 ! K  provide list of temperetures OR (nstemp and temps = tempsmin  tempsmax for even space mode)
  nsiter   = 500
  muc     = 0.21246
  dvscf_dir   = '../../test-phonon/save'
 
  nk1         = 12
  nk2         = 12
  nk3         = 1
  nq1         = 6
  nq2         = 6
  nq3         = 1

!  mp_mesh_k = .true.
  nkf1 = 60
  nkf2 = 60
  nkf3 = 1
  nqf1 = 60
  nqf2 = 60
  nqf3 = 1
 /

Ihad try to change the "max_memlt" When I came across this problem ,But it's not this parameter. So how can I solve this problem,Thanks you ! Best wish!

hpaudya1
Posts: 99
Joined: Tue Mar 21, 2017 7:11 pm
Affiliation:

Re: Solve anisotropic Eliashberg equations

Post by hpaudya1 »

Hi dhw,

It looks like you do not have enough Matsubara points in the Pade continuation. I am not sure which version of the code you are using, if it is the latest version, we have introduced a new input variable 'npade', see below;
https://gitlab.com/QEF/q-e/-/blob/devel ... n.f90#L262

The default value is 90%, see below;
https://gitlab.com/QEF/q-e/-/blob/devel ... o.f90#L154

I think, increasing it will solve your issue.

Happy EPWing,
Hari

dhw
Posts: 10
Joined: Thu Dec 03, 2020 7:46 am
Affiliation: none

Re: Solve anisotropic Eliashberg equations

Post by dhw »

Hi. Thank you very much for your answer. I used QE6.6 version, which was also used in calculation of other systems before, so I have never used this parameter. I will try this parameter is also available in QE6.6 version.

Post Reply