Error during make

This section is dedicated to compilation problems

Moderator: stiwari

Post Reply

Error during make

Post by jst »

I encountered an error while making EPW-5.7.0

The issues arose when the make file tried to access make.depend in routine ZG

In fact, unlike other part of the code, there is no make.depend in src/ZG.

The last few lines of the output from make epw are

make[2]: Leaving directory '/home/jtse/qe-7.2/EPW/src'
(mkdir -p bin)
(cd bin ; ln -fs ../src/epw.x . )
(cd ZG/src ; make )
make[2]: Entering directory '/home/jtse/qe-7.2/EPW/ZG/src'
Makefile:59: make.depend: No such file or directory
make[2]: *** No rule to make target 'make.depend'. Stop.
make[2]: Leaving directory '/home/jtse/qe-7.2/EPW/ZG/src'
make[1]: *** [Makefile:10: epw] Error 2
make[1]: Leaving directory '/home/jtse/qe-7.2/EPW'
make: *** [Makefile:129: epw] Error 1

How I can access to make.depend for ZG?

Posts: 7
Joined: Sat Jul 29, 2023 5:30 am
Affiliation: INSA Rennes

Re: Error during make

Post by mzach »


Thank you for posting this question; the error seems unexpected.

You could simply download the currently available version using:

"wget ... 7.2.tar.gz"

and then "tar -xvf q-e-qe-7.2.tar.gz"

In the folder "qe-7.2/EPW/ZG/src" you should be able to find the "Makefile" and "make.depend". You can copy those files in your directory of the version you tried to compile.

If the error persists please try to type "make" in the directory "qe-7.2/EPW/ZG/src" and let me know what error you see.

Note: if you are not planning to use ZG, you can proceed without the "make.depend" file in "qe-7.2/EPW/ZG/src".


Marios Zacharias

For EPW and ZG Tutorials please check here:

Post Reply